Opened 13 years ago

Closed 12 years ago

#9 closed enhancement (fixed)

Is it possible to add the ability to do a MMM directly from the Lazy Search

Reported by: wactuary Owned by: stuarth
Priority: minor Milestone: 2.3
Component: Plugin Version: 2.2.2
Keywords: Cc: dieterp@…

Description

Summary says it all.

Change History (11)

comment:1 Changed 13 years ago by stuarth

All my development work is on Linux, so it's not possible for me to implement this without a Linux version of MMM.

Apparently there's now a beta of MMM for Linux. I've tried it and didn't have a great deal of luck even getting that to work on its own, let alone through SlimServer?. Unfortunately, because the beta has a time-expiring trial key I don't think I'm going to be able to progress this at present.

comment:2 Changed 12 years ago by stuarth

I've now got MusicIP (the new name for MusicMagic) working on my home server so I'm able to develop for this.

I've made some initial progress (I've got the 'M' to appear for mixable lazy search track results), so it looks encouraging.

I'll do some more investigation and report back here.

comment:3 Changed 12 years ago by Dieter

  • Cc dieterp@… added

comment:4 Changed 12 years ago by stuarth

  • Milestone set to 2.2.3
  • Status changed from new to assigned

No code checked in yet, but I've got a local copy where MusicIP mixes can be created for all search types except keyword searches (and I'm working on that).

Hopefully I'll have a rough beta that can be tested in a few days, but I'm pretty confident I can get it to work now.

Due to the nature of the mixer interfaces, it's a pretty messy approach to implementing the integration (I've raised SlimBugzilla:4451 to try to address that interface in future). This means it's quite fragile, but should work OK until major work on the importers or mixers breaks something.

comment:5 Changed 12 years ago by stuarth

  • Version set to 2.2.2

I have implemented this in r222. Also available here (note that the ZIP file hasn't been updated yet so it's the LazySearch2.pn file that's needed):

http://hickinbottom.demon.co.uk/lazysearch/browser/trunk/LazySearch2.pm?rev=222

Could you give it a test and let me know whether it works for you (just drop a note in this ticket)? The MusicIP mixes should work for normal lazy search and keyword search results.

comment:6 Changed 12 years ago by Dieter

First short test looks good. The "M" is shown in all lazy searches I tried and the MusicIP mixes could all be generated.
I will test it the next days in real life.
Thanks a lot.
Dieter

comment:7 Changed 12 years ago by Dieter

It seems that LazySearch? does no longer find artists of compilation albums. And for artist which have own albums and songs on compilations only the own albums are listed when searching for artist. This is only a problem of the artist search. With the keyword search the artists of compilations are found. I don't know if this behavior changed with the latest test version 2.2.2 or if it was already before (and only not recognized).

comment:8 Changed 12 years ago by stuarth

Yes, that's what I'm seeing now as well.

For the artist search I issue the same database query as the standard search (well, not identical but it's effectively the same), and so I can see:

  1. Performing the same search using the standard player search (ie the multi-tap method), also doesn't find those artists.
  2. Searching for that artist in the web-based search also doesn't find that artist.

So, I'm pretty sure it's not LazySearch that is causing this problem but is rather to do with the contents of the database. It used to be the case that all artists on tracks in VA albums would be recorded against the album as well, which is why I'm pretty sure this used to work. However, looking into the database I now see that only one artist is recorded against those albums (which I think might be the artist of the last track on that album).

I think the cause is something to do with MusicMagic. I've tried turning off the Use MusicMagic setting under Server Settings->Basic Settings and performing a clear-and-rescan and I can now search for those artists again (and the database does list all artists against the album).

Could you confirm that you also see this with the standard forms of search and the 'correct' behaviour return whe you turn off MusicMagic? If that's the case then it's probably something you could raise on the forums more generally - I must admit that various artist handling baffles me and judging by the traffic about it on the lists I'm not alone in that! There have definitely been a lot of changes in SlimServer's handling of that in recent times so there might be an easy solution somewhere.

If this is the only issue you're seeing then hopefully we can say that MusicMagic integration in the plugin is now working - I'd like to get that pushed out this week whilst I'm off work if possible.

comment:9 Changed 12 years ago by Dieter

Yes I can confirm that it happens only with MusicMagic? on and it happens also with the standard search. I have found bug 3824 in bugzilla which could be related and have described our problem. So LazySearch? seems to be ok. As a workaround I have at the moment set the option to directly jump to the keyword search when pressing SEARCH (which finds all artists). Maybe I get used to this feature ;)

comment:10 Changed 12 years ago by stuarth

Excellent - thanks for confirming that. I've added confirmation that I see it also to SlimBugzilla:3824.

I'll just give this version of the plugin a little more testing then hopefully push it out today or tomorrow.

comment:11 Changed 12 years ago by stuarth

  • Resolution set to fixed
  • Status changed from assigned to closed

Resolved in r222.

Note: See TracTickets for help on using tickets.